[darcs-devel] [issue1118] Not showing prompt when asking for patch name

Eric Kow bugs at darcs.net
Wed Aug 26 17:27:07 UTC 2009


Eric Kow <kowey at darcs.net> added the comment:

This bug is very odd and hard to reproduce :-(
Marco, do you still get the same symptoms Darcs 2.3?

I could not reproduce it with your script.  I tried hitting 'y' a lot of times
and then 'a' but each time it hitting 'a' jumps straight to the patch name
prompt as expected.

Repeating the transcript below:

Shall I record this change? (111/120)  [ynWsfvpxdaqjk], or ? for help: a
...
Shall I record this change? (112/120)  [ynWsfvpxdaqjk], or ? for help: a

What is the patch name? Do you want to add a long comment? [yn]n
Finished recording patch 'a'

It's as if registered you hitting y 111 times but somehow displayed them wrong
so that in fact, you were answering 'y' to 111, 'a' to 112 and 'a' to the patch
name prompt.

----------
assignedto:  -> marcot

__________________________________
Darcs bug tracker <bugs at darcs.net>
<http://bugs.darcs.net/issue1118>
__________________________________


More information about the darcs-devel mailing list