[darcs-devel] [patch1095] Update containers minimum version

Guillaume Hoffmann bugs at darcs.net
Tue Aug 13 14:51:54 UTC 2013


Guillaume Hoffmann <guillaumh at gmail.com> added the comment:

I don't recall we committed to supporting only the package versions
provided by HP ( http://darcs.net/Development/Policy ). If all
dependencies are cabal-installable it should be ok no?

But indeed the current (and previous) HP provides only
containers-0.4.2.1 [1], whereas containers-0.5.0.0 was released more
than one year ago [2]. Same issue with hashable (HP provides 1.1.2.5, we
require 1.2).

Worse, some dependencies of darcs are not provided at all by HP:
haskeline, cryptohash, base16-bytestring, hashed-storage, tar, data-ordlist.

Next HP is scheduled for November 2013 [3]. I'm not familiar with the
process, maybe we can ask or vote for new versions of hashable and
containers?

[1] http://www.haskell.org/platform/changelog.html
[2] http://hackage.haskell.org/package/containers-0.5.0.0
[3] http://trac.haskell.org/haskell-platform/wiki/ReleaseTimetable

__________________________________
Darcs bug tracker <bugs at darcs.net>
<http://bugs.darcs.net/patch1095>
__________________________________


More information about the darcs-devel mailing list