[darcs-devel] [patch1441] Introduce a 'Suspended' type to encapsul... (and 12 more)

Guillaume Hoffmann bugs at darcs.net
Fri Mar 18 19:39:38 UTC 2016


Guillaume Hoffmann <guillaumh at gmail.com> added the comment:

TLDR: everything looks good, accepting.


* Introduce a 'Suspended' type to encapsulate 'FL RebaseItem':     OK

* abstract out an instance ShowPatchBasic Suspended:    OK

* inline a couple of defaults to simplify future refactoring: OK

* refactor instance ShowPatch Rebasing a bit: OK

* break out Apply instance for Suspended: OK

* break out ShowPatch instance for Suspended: OK

* add PrimPatchBase instance for Suspended: OK

* break out Effect instance for Suspended: OK

* break out Conflict instance for Suspended: OK

* break out Show instances for Suspended: OK. I was not aware of the
  StandaloneDeriving extension but it's present since at least GHC 7.4
  (see eg
 
https://downloads.haskell.org/~ghc/7.4.2/docs/html/users_guide/deriving.html
)

* break out Check instance for Suspended: OK

* break out ReadPatch instance for Suspended: OK looks correct

* break out RepairToFL instance for Suspended: OK

* use Suspended instead of FL RebaseItem in take*Rebase*:  OK, nice, it's
  the first application of the Suspended refactoring to the UI code

* rename mkSuspended to mkRebase and make it work on 'Suspended': OK

* break out PatchInspect instance for Suspended: OK

* simplify instance ShowPatchBasic (RebaseSelect p): OK

* add Repair instance for Suspended: OK

* move addFixup to Rebase.Container and give it a clearer name: OK

* add versions of simplifyPush[es] for Suspended: OK (this helps simplify
  a couple of funcions in Container)

__________________________________
Darcs bug tracker <bugs at darcs.net>
<http://bugs.darcs.net/patch1441>
__________________________________


More information about the darcs-devel mailing list