[darcs-devel] [patch2055] resolve issue2649: cleanup display of patches
bugs at darcs.net
Thu Jul 30 08:46:30 UTC 2020
Ganesh Sittampalam <ganesh at earth.li> added the comment:
> * rename [Ss]ummary to [Ww]ithSummary in Darcs.UI.*
> * resolve issue2649: cleanup display of patches
> Logically, 'description' should default
> -- to 'mempty' while 'content' should default to 'displayPatch'. We define them
> -- the other way around so that 'Darcs.UI.PrintPatch.showFriendly' gives
> -- reasonable results for all patch types.
Is it effectively a future TODO to refactor this further, or is it
fundamental? (The answer might be a useful comment either way)
> showWithSummary :: ShowPatch p => p wX wY -> Doc
> showWithSummary p = description p $$ prefix " " (summary p)
Given the above defaults, doesn't that mean that showWithSummary might
print out the whole patch followed by a summary of it?
Otherwise the patch looks fine. I haven't thought through each change in
detail but I like the principle of the introduction of 'content'.
> * RebaseChange: use nubSort instead of nub for listTouchedFiles
> * D.UI.SelectChanges: remove unused exports, rename showCur to printCurrent
Darcs bug tracker <bugs at darcs.net>
More information about the darcs-devel