[darcs-users] MinGW running problems

Gour gour at mail.inet.hr
Mon Nov 17 10:40:50 UTC 2003


Peter Strand (d98peter at dtek.chalmers.se) wrote:

> I put a couple of patches at: http://zarquon.se/repos/darcs
> 
> With these applied, darcs builds and (partially) runs under 
> windows, for me at least..
> (configured with "--disable-mmap --without-libcurl --target=mingw32")

I pulled you patches and built darcs (I added --disable-otpimize).

> 
> Hope it helps, and if it doesn't, I'd like to know why  ;)

When I run darcs inittree on a fresh directory, I get:

Fail: already exists
Action: renameFile
Reason: File exists
File: ./_darcs/inventory-0

I tried to apply workaround with removeFile, but it's obvious that my Haskell
skills are nil since with these "workaround" I get:

$ darcs inittree

Fail: does not exist
Action: removeFile
Reason: No such file or directory
File: _darcs/prefs/boring

What is your environment?

I'm running latest MinGW with MSYS (latest) under Win98.


Sincerely,
Gour

-- 
Gour
gour at mail.inet.hr
Registered Linux User #278493





More information about the darcs-users mailing list