[darcs-users] User interface for conflicts: confusing enough to lose data

David Roundy droundy at abridgegame.org
Sat Jul 31 10:30:23 UTC 2004


On Thu, Jul 29, 2004 at 10:24:02PM +0200, Juliusz Chroboczek wrote:
> >From http://www.pps.jussieu.fr/~jch/software/repos/vc-darcs/ :
> 
>        ;; darcs does not currently allow getting an old version of a
>        ;; file.  We kludge around this by getting the current version and
>        ;; reversing the right patch.

darcs annotate with appropriate post-processing does give you the old
version of a file... the "appropriate post-processing" is not particularly
pretty though.
-- 
David Roundy
http://www.abridgegame.org




More information about the darcs-users mailing list