[darcs-users] win32 problem with nestedvm.ibex.org

Jonathan Wright Jonathan.Wright at orionhealth.com
Tue May 4 21:26:48 UTC 2004


Hi all,

I just tried the "darcs get http://abridgegame.org/repos/foo" on windows
XP with darcs 0.9.19 with a windows build (not where it came from...).
It worked without a hitch. The aaack directory was empty, and there were
no other files.

Hope this helps to isolate the problem.
Jonathan.

-----Original Message-----
From: darcs-users-admin at abridgegame.org
[mailto:darcs-users-admin at abridgegame.org] On Behalf Of David Roundy
Sent: Tuesday, 4 May 2004 10:49 p.m.
To: darcs-users at abridgegame.org
Subject: Re: [darcs-users] win32 problem with nestedvm.ibex.org

On Mon, May 03, 2004 at 12:35:26PM -0700, Tupshin Harper wrote:
> There appears to be a win32 specific problem that occurs when using 
> darcs to get http://nestedvm.ibex.org.
> 
> Using a 0.9.19 win32 build (I'm using the one from
http://glozer.net/darcs/)
> 
> darcs get http://nestedvm.ibex.org
> 
> Fail: ./doc/IVME.xls: removeFile: permission denied (Permission
denied)

Hmmmm.  This is odd, and I'd like to track it down.  The file
doc/IVME.xls
*should* be removed by the "paper" patch--the most recent one, so it's a
bit mysterious where this problem comes from.  Unfortunately, the
windows
build of darcs doesn't seem to run under wine, so I'm not able to
reproduce
this bug myself (since I also don't have windows).

Any chance another haskeller on the list (who has windows...) could look
into this?

In the meantime, there are a couple of things you could do to help pin
down
what exactly is causing the trouble.  Before the latest patch ("paper")
was
the win32 darcs able to run "get" on the repo just fine? If you don't
know,
you could unpull that patch from a scratch copy of the repo and try
getting
from there.

There is another (earlier) "remove file" patch, which doesn't seem to be
causing trouble, so the only think that seems unique about this patch is
that the IVME.xls file was treated as binary.

Could you try running (with the win32 darcs, of course):

darcs get http://abridgegame.org/repos/foo

This is a simple test repo that creates a couple of binary files and
removes them.  If all works fine the repo has in it just an empty
directory
named aaack.

I think I've already exhausted my troubleshooting ideas... but hopefully
if
your answers to these questions don't reveal the problem I'll come up
with
something else...
-- 
David Roundy
http://www.abridgegame.org

_______________________________________________
darcs-users mailing list
darcs-users at abridgegame.org
http://www.abridgegame.org/mailman/listinfo/darcs-users




More information about the darcs-users mailing list