[darcs-users] another confusion re: command names

Jan Braun janbraun at gmx.de
Tue May 11 02:00:16 UTC 2004

sorry David, you're getting this twice :(

David Roundy wrote:
> On Thu, May 06, 2004 at 11:24:39AM -0400, zooko at zooko.com wrote:
> >
> > By the way, I had previously been doing "unpull" by "unrecord; revert".
> This is what I hope that new users will do.  When you unrecord and then
> revert, you're much less likely to accidentally delete a change you made
> and not be able to get it back (especially since unrevert exists).
> The intention of this "interesting" naming convention is that people who
> don't understand exactly how unpull and unrecord differ (which is everyone
> at first) will not end up accidentally using unpull when they want
> unrecord, and losing their precious data.  Then when they have that "aha"
> moment when they see that unpull is like an unrecord that also reverts the
> working directory (and also understand what this means), they can start
> using unpull instead of "unrecord; revert".

Then wouldn't it be better to remove the unpull command altogether and create
an "--and-revert" option to unrecord? This should be quite self-explanatory,
makes the possibly unsafe unpull operation more explicit to type and leaves
the user with one fewer command name to keep in his head.
Plus it *guarantees* users know unrecord and revert before using "unpull" ;)

> Of course, the documentation should make this "aha" moment come as soon as
> possible, which I don't think it was really doing.  The --help text doesn't
> have that goal (currently)--it is mostly designed to prevent people from
> using unpull if they don't understand it.

The problem is people getting confused (rather than just ignoring unpull) if
they don't understand it.

Or, if you think unpull is important enough to deserve its own command, you
could still add "unrecord --and-revert", make it the advertised solution, and
present unpull as a convenience alias.

Just my .02 cent,

More information about the darcs-users mailing list