[darcs-users] bug report: "darcs replace --force" doesn't force ?

zooko at zooko.com zooko at zooko.com
Wed May 12 16:22:00 UTC 2004


Doesn't "--force" mean "go ahead even if one of the files already contains
'pyutil.__version__'?

Transcript follows.  Regards, Zooko


HACK pion:~/playground/mn/mnet_new_mt$ find . -name '*.py' | grep -vEe"^./(_darcs|build)/|__init__.py" | xargs darcs replace --force --token-chars '[A-Za-z0-9\._]' pyutil.version.version pyutil.__version__

darcs failed:  Can't do replace on working!
Perhaps one of the files already contains 'pyutil.__version__'?





More information about the darcs-users mailing list