[darcs-users] Command renamings and hide/show
kknowles at berkeley.edu
Thu May 13 16:22:21 UTC 2004
I'll give my votes:
On Thu, May 13, 2004 at 07:08:45AM -0700, Kevin Smith wrote:
> >* Rename 'repository' to 'branch' throughout
> I agree with the other poster that people have negative connotations
> with branches.
I like repository, because the word "branch" exists to distinguish it from
"trunk" which would be the default. So "branch" implies an exceptional state
to some degree, which is not the case in darcs.
> >* Make the default to be as verbose as possible, and offer -q /
> Yes, probably.
I like this, but don't feel strongly about it.
> >* The default should be that no patch is deleted without a warning
> I think so.
I like this too, though overriding it would be necessary for scripting.
> >* It should be easy to temporarily get a patch out of the way,
> I don't think this should be in 1.0.
Whatever works for the maintainers. I've never had a desire to use this.
> > get "branch" or "mkbranch", with explicit option --and-
> I like having 'get' as a separate command from 'pull'. At least in my
> mind, one creates a repo, but the other one adds to an existing repo.
"get" is easy to understand and concise, I'm strongly opposed to changing it. I
agree with Kevin's rationale as well.
> > inittree "branch --root" or "branch --trunk" or just "trunk" or
> initrepo or just init or initialize might be better.
I like just "init" because it is just as clear, and less characters :-)
Also, you dodge the whore repo/branch/tree vocabulary mess.
> > unpull "unrecord --and-delete" or something like that,
> > * send->export and apply->import: this has more symmetry, and removes
> > the strange "send --output" combination.
> Seems reasonable, but I don't have strong feelings about it.
I too do not feel strongly about it. I think the intuition of "send" might be
nice, but I've never used it.
> > * add->control and remove->uncontrol: this removes any confusion
> > between "darcs remove" and "rm". (Or perhaps "ignore" instead of
> > "uncontrol", but that has less symmetry.)
> Archipel uses "track" and "untrack", which I like. But I'm not convinced
> this needs to be changed.
I strongly dislike this change. "add" and "remove" are nicely symmetrical, and
its very common (and easy to deduce even if you didn't know before) that source
control will leave a file even when it has relinquished control.
On that note, is there a feature of darcs like CVS where you say "cvs remove"
and anything in the repo that is gone from the directory shows up? This would
be like --look-for-adds in reverse.
More information about the darcs-users