[darcs-users] darcs for FC3?

Andres Loeh andres at cs.uu.nl
Thu Nov 18 17:44:02 UTC 2004


> I want to try darcs on Fedora 3.  I tried to rebuild the srpm for ghc, but
> it fails.  I installed the ghc from FC1 in order to boostrap.
> 
> rpmbuild --rebuild
> http://haskell.org/fedora/haskell/current/i386/SRPMS.stable/ghc-6.2.1-0.fdr.1.src.rpm
> [...]
> /usr/bin/ghc -H16m -O -cpp -DPKG_TOOL -DWANT_PRETTY -DGHC_PKG_VERSION=6.2.1   
> -c Main.hs -o Main.o  -ohi Main.hi
> Main.hs:87: warning: backslash and newline separated by space
> Main.hs:259: warning: backslash and newline separated by space
> Main.hs:260: warning: backslash and newline separated by space
> Main.hs:87: lexical error in string/character literal
> make[4]: *** [Main.o] Error 1

ghc-6.2.1 has problems with the latest gcc's. Try to get hold of
a ghc-6.2.2 srpm.

HTH,
  Andres




More information about the darcs-users mailing list