[darcs-users] darcs-1.0.0 on sun-sparc-solaris2.6

Nicolas Pelletier nicolasp at nortelnetworks.com
Fri Nov 19 16:52:42 UTC 2004


Hello,

I  am  happy  to  report  that  darcs  1.0.0  builds  and  runs  on  a
sun-sparc-solaris2.6 machine. The binary  was produced with ghc 6.2.1,
gcc 2.95.2 and GNU make 3.80.

I had  however to add the flags  -lposix4 -lpthread to get  it to work
right.   Otherwise, darcs  record  would fail  when  trying to  record
compressed patches (the call  to pthread_create in zlib_helper.c would
fail).

-- 
Nicolas




More information about the darcs-users mailing list