[darcs-users] Re: from --partial to --complete?

David Roundy droundy at abridgegame.org
Thu Nov 25 11:46:04 UTC 2004


On Wed, Nov 24, 2004 at 12:51:18PM +0100, Karl Hasselstrm wrote:
> On 2004-11-24 06:36:49 -0500, David Roundy wrote:
> 
> > There is a question at to how to do this right. It would potentially
> > be nice to make the --partial repository upgrade itself when you
> > perform a command that requires the older patches. On the other
> > hand, that could be bad in that it could lead to unpredictable
> > costs. e.g. darcs changes foo could require that you download the
> > entire repository, which may not be what you want.
> 
> It could just prompt the user, saying that it will need to get more of
> the history in order not to fail. (And there should be command line
> switches --remote-history and --no-remote-history for noninteractive
> runs.)

Yes, that would be a good way to do it.
-- 
David Roundy
http://www.darcs.net




More information about the darcs-users mailing list