[darcs-users] Re: fixing conflicts in darcs

David Roundy droundy at abridgegame.org
Tue Nov 30 13:04:20 UTC 2004


On Tue, Nov 30, 2004 at 01:31:41PM +0100, Erik Bgfors wrote:
> But, still, why can't I unpull? everytime I do that I get
> darcs failed:  Couldn't commute patch past pending.

If you want to unpull the conflicting patch, you need first to revert the
conflict marking.  But if you want to amend-record your patch (the one that
hasn't been pushed, and is private), you don't need (or want) to unpull the
conflicting patch first.  You just edit the files (to resolve the conflict)
and then run amend-record, which will prompt you for which patch you want
to amend.
-- 
David Roundy
http://www.darcs.net




More information about the darcs-users mailing list