[darcs-users] Re: Endless loop when pushing

Stephane Bortzmeyer bortzmeyer at nic.fr
Tue Nov 30 15:21:36 UTC 2004


On Tue, Nov 30, 2004 at 03:19:09PM +0100,
 Stephane Bortzmeyer <bortzmeyer at nic.fr> wrote 
 a message of 15 lines which said:

> I just pushed the very same repository to a fresh machine (which has a
> brand new repository, just created with "cards init") and it works in
> minutes. So, you are right, it was certainly a conflict issue.
> 
> Now, how to solve it, besides deleting everything and restarting from
> zero?

First attempt (which failed):

I have a machine where development was done (fetiche, the initiator)
and one on which I want to push the change (vespucci, the target).

All the development I want to retrieve is in one subdirectory,
something I can check by 'zgrep -e "add(dir|file)"
_darcs/patches/$PATCH'.

On the target, vespucci, the subdirectory does not exist. It existed,
but I deleted it and ran a 'darcs remove'.

Both darcs repository are locally up-to-date ("darcs record" finds
nothing to record and says "No changes!").

But I still have the same problem. fetiche pushes, the darcsXVZzpw
file is copied to vespucci and then darcs just run forever on the
target machine.

If I push to a machine where the repository is completely new, it
works. But, in my case, while the repository on vespucci is not new,
I should not see any conflict because changes are in one directory,
which no longer exist on the target.






More information about the darcs-users mailing list