[darcs-users] Pushing from X to Y fails while pulling from X to Y succeeds

Ilja Honkonen ilja.honkonen at helsinki.fi
Sun Mar 6 14:27:36 UTC 2005


David Roundy wrote:
> On Sun, Mar 06, 2005 at 11:27:50AM +0200, Ilja Honkonen wrote:
> 
>>Hello
>>
>>I added some files to my repository and recorded the changes. Then I 
>>tried to push that patch to another repository with
>>darcs push ~/koti.mbnet.fi/foo
>>and darcs replied
>>Fail: Bad patch bundle!
>>Eventually I tried pulling the patch from the repo in 
>>~/koti.mbnet.fi/foo with
>>darcs pull ~/ohjelmointi/c/foo
>>and it succeeded.
>>Why? What else do you need to know?
>>
>>The repo in ~/ohjelmointi/c/foo is on a local drive and the repo in 
>>~/koti.mbnet.fi/foo is mounted with fuse (http://fuse.sourceforge.net/) 
>>and lufis 
>>(http://sourceforge.net/project/showfiles.php?group_id=121684&package_id=132803) 
>> from a ftp/http server koti.mbnet.fi
> 
> 
> Do you get the same error if you
> 
> cp -a ~/koti.mbnet.fi/foo /tmp/foo
> darcs push /tmp/foo

No, it applies fine

> Push creates an intermediate patch bundle that is then applied using darcs
> apply.  It seems that somehow the patch bundle is becoming corrupted, which
> is odd.

Maybe I'm running out of disk space on koti.mbnet.fi?
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda2              41G   37G  1.7G  96% /
none                  251M     0  251M   0% /dev/shm
df: `/home/Ilja/koti.mbnet.fi': Function not implemented




More information about the darcs-users mailing list