[darcs-users] Re: argh. please change the name "unpull"
mark at summersault.com
Thu Mar 17 22:17:06 UTC 2005
On 2005-03-17, Thomas Zander <zander at kde.org> wrote:
> I certainly believe we should optimise for the finding of the right command=
> first. And UnPull being the opposite of Pull in actual usage makes me feel=
> it really is the best name. Erase is not what I would pick from a list of=
> items if I wanted to undo a pull action.
But 'pull' is a copy. So how is a copy undone? It's not 'uncopied',
The second copy is discarded.
Realize that 'unpull' is also used for:
- removing patches that have never left the repo, but were recorded with 'record'
- patches that have been applied manually with 'apply'.
- patches that have been been applied automatically through an e-mail system.
In all cases the patch is applied with 'apply' at some point, which is
why I think I'm leaving my vote on 'unapply'.
More information about the darcs-users