[darcs-users] Re: argh. please change the name "unpull"

Peter Hercek peter at syncad.com
Fri Mar 18 09:21:29 UTC 2005


I second this. Especially the part about optimization of finding
  the right command first. Naming consistency and groping helps
  here. Shortcuts / separating words in commands with dash in
  one command name only? No grouping at all in the help message
  currently?

Unpull sounds best. Moreover I think the command should be safe
  and allow unpulling only when it was pulled (or maybe applied).

If you want to destroy data in your repository you can still use
  unrecord and revert together. Again unrecord should be safe and
  should not allow you to do it if the patch was pushed/sent.

Darcs command names are based on the typical workflow and not based
  on what physically the command does (which data stores (working
  copy, this repository, another repository) does it modify). This
  leads to comfortable interface in most cases but the interface
  is not orthogonal. That's ok. It was chosen that way. But it also
  means it should continue that way. Otherwise the interface which
  is not very consistent now (shortcuts, word division), will be
  even more inconsistent.

Keep the naming strategy the way you started. Do not try to mix
  names based on workflow with names based on what the command
  actually modifies.

I hope I expressed myself good enough and this is understandable.

Peter.


Thomas Zander wrote:
> On Thursday 17 March 2005 22:11, Zooko O'Whielacronx wrote:
> 
>>>Another option is to explain the reasoning behind the naming; it is to
>>>undo the pulling.
>>
>>This might persuade my boss that "unpull" is a good name, but it won't
>>give me my five minutes back.  Also it would take up more of my
>>minutes.  ;-)
>>
>>Seriously, the name "unpull" wastes people's 5-minutes.  That's
>>sufficient reason to change it, even if it is a good name once you've
>>understood it.
> 
> 
> In real live more people find out _how_ to do things by searching for the 
> right command then the thing you explained here; which is to explain _why_ 
> a certain command is named as it is.
> 
> I certainly believe we should optimise for the finding of the right command 
> first.  And UnPull being the opposite of Pull in actual usage makes me feel 
> it really is the best name.  Erase is not what I would pick from a list of 
> items if I wanted to undo a pull action.
> 
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> darcs-users mailing list
> darcs-users at darcs.net
> http://www.abridgegame.org/mailman/listinfo/darcs-users





More information about the darcs-users mailing list