[darcs-users] Re: argh. please change the name "unpull"
quaggy at gmail.com
Sat Mar 19 08:15:44 UTC 2005
On Sat, 19 Mar 2005 08:48:52 +0100, Thomas Zander <zander at kde.org> wrote:
> On Friday 18 March 2005 23:07, Quag wrote:
> > On Fri, 18 Mar 2005 22:55:46 +0100, Ivan Stankovic
> > <pokemon at fly.srk.fer.hr> wrote:
> > > Yes, "drop" seems nice, especially if you consider how often it is used
> > > in expressions like "dropping a patch". If the name has to be changed
> > > (though I don't have anything against unpull), I'd go for "drop".
> > Yup, "drop" is good. Any objections?
> David wrote this some time ago 
> > Since unpull is perfectly safe when used on pulled patches, I'd rather
> > give it a nice unscary name that reflects that, rather than a scary name.
> > In my experience it's very rare that I unpull a patch that wasn't gotten
> > either by a pull or an apply (and usually it's a pull).
> The objection I have against 'drop' is that unpull shows a workflow and drop
> shows the function. Darcs works because its workflow optimized, tla does
> not work because its just a bunch of functions the user has to find out how
> to best put in a workflow. (which is the unix way)
I agree with a workflow approach, and for this reason drop is not a
great name, but it still isn't an argument to keep unpull as the name.
Unpull currently describes a number of workflow tasks: 1) unpull, 2)
unapply, 3) discard-a-record, 4) get-rid-of-a-patch-someone-pushed,
and so on. We could create aliases so that there was a proper workflow
based name for them, but then we're back to the aliasing problem.
I really can't see a way to get out of this problem without using a
function based name. Maybe it is time to invent a new word. :)
More information about the darcs-users