[darcs-users] compiling darcs with ghc-6.4 failed

Andrei A. Voropaev av at simcon-mt.com
Mon Mar 21 10:33:10 UTC 2005


Hi!

I'm trying to compile darcs because I don't use any standart
distribution. So I got me ghc-6.4 and tried to run configure for darcs.
It failed complaining that it can't figure out how to do OpenFd. After
that I've downgraded to ghc-6.2.2 and everything worked fine.

Is that a normal thing that each new version of Haskell compiler can't
compile code written for older versions? Or is it some problem in the
distributions of ghc that I'm using? (I had downloaded binaries for i386
from ghc web-site)

Is there a newer package for darcs that can be compiled with ghc-6.4?
I'd like to compile it on x86_64 and for that so far I can get only
ghc-6.4

Thank you

-- 
Minds, like parachutes, function best when open




More information about the darcs-users mailing list