[darcs-users] get and put should be 'get-repo' and 'put-repo'

Mark Stosberg mark at summersault.com
Mon Mar 21 17:21:45 UTC 2005


All darcs subcommands are verbs. Mostly they operate on the same nouns,
patches, so it isn't a problem that we also don't include a noun in the
name to include whath the operate on. Some, like 'diff' operate on
patches and/or files, which would make it difficult to choose the best noun anyway. 

Just a few operate primarily on repositories.  These are:

    get
    put
    initialize
    optimize
    check
    repair

Of these, 'get' and 'put' risk confusion, because they are similar to
the concepts of 'push' and 'pull'. Thus, I think they should be
clarified as: 

 get-repo
 put-repo

Due to darcs abbreviation mechanism, they can still be used as 'get' and
'put', but I think the more specific names will help new users see an
immediate difference with 'push' and 'pull' in the help menus and
documentation.

    Mark





More information about the darcs-users mailing list