[darcs-users] Re: argh. please change the name "unpull"

John S. Yates, Jr. jyates at netezza.com
Mon Mar 21 17:56:04 UTC 2005


"Quag" <quaggy at gmail.com> wrote in message

> I agree with a workflow approach, and for this reason drop is not a
> great name, but it still isn't an argument to keep unpull as the name.
> Unpull currently describes a number of workflow tasks: 1) unpull, 2)
> unapply, 3) discard-a-record, 4) get-rid-of-a-patch-someone-pushed,
> and so on.

Impression from a newbie trying to internalize a sense of the darcs
commands:

It is important that the common understanding that a new user brings to
the learning experience pan out.  As a learning barrier false similarity
is worse than opaque names to be learned by rote.  (So, given that unpull
generates so much controversy would we be better off calling it cdr :-)

It seems to me that unpull is inherently part of "cherry picking".  If
that is the case then emphasizing selection might help.  How about names
like decline? reject? omit? skip?

/john








More information about the darcs-users mailing list