[darcs-users] get and put should be 'get-repo' and 'put-repo'
ralph at inputplus.co.uk
Tue Mar 22 09:49:57 UTC 2005
Hi Thomas and Mark,
> On Monday 21 March 2005 18:21, Mark Stosberg wrote:
> > I think they should be clarified as:
> > get-repo
> > put-repo
> > Due to darcs abbreviation mechanism, they can still be used as 'get'
> > and 'put', but I think the more specific names will help new users
> > see an immediate difference with 'push' and 'pull' in the help menus
> > and documentation.
> A much less painfull and similarly good solution (IMO even better) is
> to make darcs pretty print the command overview. You know; group
> commands and all that.
The two ideas seem distinct and I'd vote +1 for each of them. Omit the
`noun' when it's the common one and specify it otherwise.
More information about the darcs-users