[darcs-users] Re: get and put should be 'get-repo' and 'put-repo'

Peter Hercek peter at syncad.com
Tue Mar 22 09:36:23 UTC 2005

I plan to do that if somebody else will not be quicker.
  I will not be quick since I need to learn Haskell first
  (I'm somewhere in the first quater of the manual).
  Fortunatelly, it is not too different from OCAML.

Another problem with the way how darcs prints help is that
  the the texts use explicit line breaking. It is a major
  pain if you want to reformat somethign to 80 characters
  width after modifying one line of the text.

Also I have noticed the flag --extended-help which seems
  either redudntant or wrong in its current form.

Thomas Zander wrote:
> On Monday 21 March 2005 18:21, Mark Stosberg wrote:
>> I think they should be
>>clarified as:
>> get-repo
>> put-repo
>>Due to darcs abbreviation mechanism, they can still be used as 'get' and
>>'put', but I think the more specific names will help new users see an
>>immediate difference with 'push' and 'pull' in the help menus and
> A much less painfull and similarly good solution (IMO even better) is to 
> make darcs pretty print the command overview.  You know; group commands and 
> all that.
> ------------------------------------------------------------------------
> _______________________________________________
> darcs-users mailing list
> darcs-users at darcs.net
> http://www.abridgegame.org/mailman/listinfo/darcs-users

More information about the darcs-users mailing list