[darcs-users] Re: .darcs is portable

zooko zooko at yumyum.zooko.com
Thu Mar 31 15:37:02 UTC 2005


> 	(two days pass...is this directory under revision control?  What shall 
> I do?)
> 
> 
> dustinti:/tmp/blah 512% darcs init
> 
> darcs failed:  Unable to "darcs initialize" here.

I do this all the time.  Probably twice a day I run "darcs init" in some 
directory that I rarely visit just in case I forgot to create the repo here last 
time.

Unfortunately there is a bad failure mode: if I forget darcs will happily make 
my changes in a repo which exists higher up in my file system.  This is often 
Very Bad, such as when I run a script that records hundreds of changes and then 
realize that instead of making them in /home/zooko/playground/pyutil it was 
making them in /home/zooko!  

At least it wasn't making them in /, since that would require superuser write 
privs.  ;-)

When this happened, I had to use darcs init;darcs pull to fetch the patches 
I wanted from my home dir repo, then remove it and move the new repo into its 
place, because I didn't want to manually unpull hundreds of patches from it.

Note: if every level of filesystem above the current working directory doesn't 
have a separate darcs repo in it, then you ought to use darcs more, or else have 
a shallower filesystem tree.  ;-)

--Z





More information about the darcs-users mailing list