[darcs-users] The infamous 'Unapplicable patch'

Bill Trost trost at cloud.rain.com
Wed Jan 3 04:23:09 UTC 2007

I have a patch buried pretty deep in my repository that darcs is barfing
on with the message

  Applying patch 325 of 481... Unapplicable patch:
  Fri Sep 29 07:28:38 PDT 2006  trost at cloud.rain.com
    * Post-game discussion

  darcs failed:  Error applying hunk to file ./secrets/ToDo

when I do a "darcs check --complete".  I've tried Getting the repository
from a new one, with much the same results.  I tried Getting with
--no-dep, and that took all day before I had to give up.  Deleting
and/or messing with the patch doesn't seem promising, largely because
the patch is on a file that's seen lots of changes since then.

What to do now? I have no idea how the repository got into this state,
since the patch is from months ago. Is there any way to swamp things
out? Do I cut my repository off at the latest checkpoint? Do I give
up on my history completely and start over (likely with a different

Thanks for any assistance,

More information about the darcs-users mailing list