[darcs-users] GHC 6.10 compatibility patches

J. Garrett Morris jgmorris at cecs.pdx.edu
Fri Oct 17 16:28:48 UTC 2008


Hello everyone,

In the process of testing the franchise build on Vista, I discovered
that GHC 6.10 complains about several warnings which stop the build
process because of -Werror.  They are: -fffi is deprecated, and unused
imports.  I've attached a patch which resolves these issues.  I don't
know when -XForeignFunctionInterface was introduced though, or how to
make the GHC flags dependent on GHC version, so this might be the
wrong idea.

I hope I got the patches attached correctly - this is my first shot at this.

 /g

-- 
I am in here
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ghc-6.10-compatibility-patches
Type: application/octet-stream
Size: 57826 bytes
Desc: not available
Url : http://lists.osuosl.org/pipermail/darcs-users/attachments/20081017/8868d32b/attachment-0001.obj 


More information about the darcs-users mailing list