[darcs-users] darcs patch: Import cabalisation: Setup.lhs, darcs.ca... (and 13 more)

Jason Dagit dagit at codersbase.com
Mon Oct 20 07:55:04 UTC 2008


On Mon, Oct 20, 2008 at 12:43 AM, Eric Kow <kowey at darcs.net> wrote:

>
>
> For now it's franchise that's doing all of the work.  The patch
> (actually the revised patch I sent later) brings us to a cabal/franchise
> mix of 10/90.  I intend to post a summary in the original enfranchising
> darcs thread.


Okay, then I hope we can all agree to leave the existing autotools build
system in place until all that is sorted out.  Those of us without franchise
would still like to be able to build darcs :)


> I'm afraid I don't understand the question.  The Haskell package
> dependencies
> are written by hand in the Cabal file and are simply not used, except maybe
> by
> cabal-install.


Right, cabal lets you specify things unambiguously but someone pointed out
in a different thread on this mailing list that if you have parsec 2 and 3
(which is the case for me), that franchise picks the wrong one.

Thanks Eric,

Jason
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osuosl.org/pipermail/darcs-users/attachments/20081020/137db1b9/attachment.htm 


More information about the darcs-users mailing list