[darcs-users] [darcs-devel] buildbot failure in darcs on zooko allmydata virtual2 Windows-XP i386

Eric Kow kowey at darcs.net
Sun Oct 26 07:33:27 UTC 2008


On Sat, Oct 25, 2008 at 19:35:08 -0600, zooko wrote:
> Sorry, I don't understand and I don't have time to investigate right  
> now.  I tried a darcs pull from the buildmaster config repo at  
> community.haskell.org:/src/code/darcs/buildbot but there were no new  
> patches.

It was this patch:

Mon Oct 20 11:14:19 BST 2008  Eric Kow <E.Y.Kow at brighton.ac.uk>     
  * Add a trailing slash to buildbotURL
  Buildbot failure reports were getting messed up (builbot.darcs.netbuilders...)
  The right solution is probably to modify how paths get concatenated...

Sorry! And this isn't the first time I've wasted people's time with poor
communications.  What I meant to say was that buildbot failures are hard
to click through to because the URL is wrong:

We get:
 http://builbot.darcs.netbuilders
when we should get:
 http://builbot.darcs.net/builders

Easy to fix, see above patch.  Thanks!

Btw: I think you meant code.haskell.org:/srv/code/darcs/buildbot or
http://code.haskell.org/darcs/buildbot

For what it's worth, when I push to kowey at code.haskell.org:/srv/code/darcs/buildbot
darcs automatically sets my _darcs/prefs/defaultrepo . But since I want
to avoid typing my password all the time, I have also put the following
entry into my _darcs/prefs/defaults:
  pull remote-repo http://code.haskell.org/darcs/buildbot

It's a useful trick to avoid ssh'ing when you don't have to

-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
Url : http://lists.osuosl.org/pipermail/darcs-users/attachments/20081026/6ef5d81f/attachment.pgp 


More information about the darcs-users mailing list