[darcs-users] Help with team upgrade on Windows

Yitzchak Gale gale at sefer.org
Mon Oct 27 09:12:12 UTC 2008


I wrote:
>> 1. Which Windows binary should I deploy, and where
>> do I get it?

zooko wrote:
> Please try this one:
> https://zooko.com/darcs/darcsdir-w32-2.0.0.zip

OK, thanks!

That zip also contains all of the PuTTY stuff. Is that
required - or can I give them a zip with just the binary
and have them drop it into their current darcs directory,
replacing the old EXE?

>> 2. What *simple* *fool-proof* instructions can I
>> give to my users to deploy the upgrade?

> If you deployed darcs-1 by using the predecessor zip file...

Yeah, an older one though.

> then following these instructions should not break anything:
> http://wiki.darcs.net/DarcsWiki/WindowsConfiguration

Well, that's what they did to begin with. With some additional
site-specific stuff from our internal wiki. Why do they need
to go through all of that again?

>> Other than deploying the binary, my main concern
>> is avoiding problems with darcs finding the wrong
>> copy of PuTTY or not finding the SSH agent.

> I don't think it matters which copy of putty the darcs executable uses.

We definitely have had problems of putty not finding the agent
when launched by darcs, and we suspect that it has something
to do with the wrong copy of putty being launched. Could it be
that the putty binaries distributed together with darcs are
somehow different than what you get when you install the
latest version of putty from the web?

Thanks,
Yitz


More information about the darcs-users mailing list