[darcs-users] Help with team upgrade on Windows

Trent W. Buck trentbuck at gmail.com
Tue Oct 28 01:45:15 UTC 2008


"Trent W. Buck" <trentbuck at gmail.com> writes:

> On Mon, Oct 27, 2008 at 01:22:58PM +0200, Yitzchak Gale wrote:
>> > The program Darcs 2 is backwards compatible with Darcs 1 repository
>> > format (called "old-fashioned-inventory").  Even if you can't upgrade
>> > all hosts to use the Darcs 2 program, you will still get a superior
>> > experience by upgrading some hosts to the Darcs 2 program while keeping
>> > your repositories in old-fashioned-inventory format.
>> 
>> The problem is that 2.1.0 by default will create V2 repos, which won't
>> be supported by 1.0.9rc1 on the server. Even if it's possible to get 2.1.0
>> to create V1 repos by some configuration or by using some flag, it's
>> not always practical to do that across a whole team of people.
>
> Ah sorry, I had forgotten about that change since 2.0.2.
>
>> Well, I hope lenny will be released soon, and that we'll be able to
>> upgrade the server not too long after that. Until then, it looks like
>> we'll be stuck with 1.0.9rc1 on the server and 2.0.x on the clients.
>
> FWIW it's unlikely that Lenny will ship with anything newer than
> 2.1.0, because it is already frozen.

Sorry, I meant anythign newer than 2.0.2.



More information about the darcs-users mailing list