[darcs-users] Help with team upgrade on Windows

Max Battcher me at worldmaker.net
Tue Oct 28 04:15:51 UTC 2008


"Trent W. Buck" <trentbuck at gmail.com> writes:
> Thinking more on this, it seems to me that "makes darcs1-incompatible
> repos by default" is only an issue when using darcs initialize -- which
> IME does not happen very often.
> 
> Could you get away with simply setting a policy that users should only
> run "darcs initialize" on the Etch server, rather than on their
> workstations?

Keep in mind that you could also enforce it at the defaults level by adding
this:

initialize old-fashioned-inventory
initialize plain-pristine-tree

in files like:

C:\Documents and Users\Username\.darcs\defaults (XP)
C:\Users\Username\.darcs\defaults (Vista)
/home/username/.darcs/defaults (Posix)

Some companies/working groups already have a standardized defaults file, and
rolling out one should be as simple/simpler than rolling out updates to
darcs itself.

--
--Max Battcher--
http://worldmaker.net



More information about the darcs-users mailing list