[darcs-users] [patch65] remove commutex

Ganesh Sittampalam ganesh at earth.li
Sat Dec 5 16:38:21 UTC 2009

On Tue, 24 Nov 2009, Jason Dagit wrote:

>> No, but I didn't really like the toCommute/fromCommute names at all, so was
>> erring towards asking that they be changed before it's applied. Hadn't
>> thought of good alternatives yet which is part of the reason I haven't
>> finished the review yet.
> I struggled with the names too.  They transform the argument tuples.
> Similar to curry/uncurry.  So the better names might be, forwardCommute and
> reverseCommute.  Or, toForwardCommute/toReverseCommute, but those are
> getting pretty long.

Sorry for the delay on this. I think the rest of the patch is fine and a 
good thing, but please do change the names. Either of your suggestions if 
fine, I think I prefer toForward and toReverse (could abbreviate to toFwd 
and toRev?). Also I suggest dropping the comment about them being to help 
the refactor from commutex, because once commutex has gone they are 


More information about the darcs-users mailing list