[darcs-users] cabal-install bootstrapping fails on Ubuntu 9.10 / Karmic Koala

Mark Stosberg mark at summersault.com
Tue Dec 8 03:44:29 UTC 2009


On Mon, 07 Dec 2009 12:39:24 +1100
twb at cybersource.com.au (Trent W. Buck) wrote:

> Mark Stosberg <mark at summersault.com> writes:
> 
> > I'm having trouble installing "cabal-install 0.6.2" on a new laptop
> > today, on Karmic Koala.
> 
> cabal-install is available in Lucid[0].  You might be able to simply
> backport that version, since the ghc6 versions in karmic and lucid are
> identical.  

Thanks for the suggestion to check in Lucid, Trent. 

By reviewing the Debian package, I was able to see what the dependencies were,
and then install them manually on Karmic before running ./bootstrap.sh:

 sudo apt-get install haskell-devscripts cdbs libghc6-http-dev libghc6-network-dev libghc6-zlib-dev

I'm not sure which of those made the difference, but "cabal install" completed
after I had done that. 

     Mark

-- 
http://mark.stosberg.com/





More information about the darcs-users mailing list