[darcs-users] git-darcs-import - howto base4

Marc Weber marco-oweber at gmx.de
Tue Dec 8 12:02:47 UTC 2009


>    From the darcs developer point of view, we really want what your
>    proposing, but we need someone to champion the effort and help maintain
>    the GUI once it's built.* Are you ready to take on that responisibility?

Right now darcs appear to be a burden to me because I have to maintain
it as well when working with many haskell packages.

Today I spend some more time improving the hack-nix system. Now I can
even fetch and update darcs libraries automatically.

However one point is bothering me: darcs is using base-3 by default.
Using most up to date versions on hackage there is no solution to build
darcs without tweaking many .cabal files. This is all due the base-3
constraint. So what about dropping it and going base4?
What's the reason for not having done it yet?

The patch file I posted earlier already contained a quick hack using CPP
to use Control.Exception or Control.OldExceptions depending on base
version.

It seemed to work. However there is anther alternative: Using extensible
excpetion package from hackage. Then the new Exceptions can be used with
base3 as well AFAIK.

What do you prefer?

How would you make darcs work with base4 ?

I'm interested learning more about FRP.

So discuss base 4 with me and we can see how much I can help.

Marc Weber


More information about the darcs-users mailing list