[darcs-users] darcs needs text pkg, which fails to build on GHC 6.8

Eric Kow kowey at darcs.net
Wed Dec 23 17:05:01 UTC 2009


Hi Bryan,

Darcs has recently started using 'text' package, but we're
having some trouble building it on GHC 6.8.

This is preventing us from getting a somewhat sizeable change [1] into
our upcoming Darcs 2.4 release in January.

We're not prepared to drop GHC 6.8 support yet, but we're not
particularly looking forward to rolling back our change.  Do
you think you could help?

We can't install text >= 0.6 because:

  cabal: cannot configure syb-0.1.0.3. It requires base >=4.0 && <4.3
  For the dependency on base >=4.0 && <4.3 there are these packages:
  base-4.0.0.0, base-4.1.0.0 and base-4.2.0.0. However none of them are
  available.

We can't install older versions of text because we get:

  [ 7 of 26] Compiling Data.Text.Encoding.Error ( Data/Text/Encoding/Error.hs, dist/build/Data/Text/Encoding/Error.o )

Data/Text/Encoding/Error.hs:87:9:
    Type constructor `Exception' used as a class
    In the instance declaration for `Exception UnicodeException'

Many thanks!

[1] Storing patch metadata in UTF-8, http://bugs.darcs.net/issue64

-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20091223/83f4677d/attachment.pgp>


More information about the darcs-users mailing list