[darcs-users] darcs needs text pkg, which fails to build on GHC 6.8

Jason Dagit dagit at codersbase.com
Thu Dec 24 07:12:26 UTC 2009


A heads up to other darcs devs and users.

text appears to require a C library for unicode.  Cabal isn't much
help here since it doesn't integrate with the locally installed
package managers (when present).  The cabal error is that the C
library "icuuc" is missing.  At least on debian/ubuntu the name is
libicu-dev.  I suspect this is the case on other platforms as well
because googling for icuuc was not terribly fruitful.

Does anyone know how our windows users will get this library?

I'm mildly annoyed because I don't recall seeing a heads up about
bringing in more non-hackage dependencies and now I'm worried about
our window support.

Back to your regularly schedule darcs-users...

Jason

On Wed, Dec 23, 2009 at 10:15 AM, Eric Kow <kowey at darcs.net> wrote:
> On Wed, Dec 23, 2009 at 09:49:11 -0800, Bryan O'Sullivan wrote:
>> > We can't install text >= 0.6
>>
>> I just published text 0.7.0.1, which builds cleanly with 6.8.3 for me.
>
> Thanks for the quick response.
>
> I confirm that text and consequently darcs HEAD build cleanly with GHC
> 6.8.3.
>
> --
> Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
> PGP Key ID: 08AC04F9
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.9 (GNU/Linux)
>
> iEYEARECAAYFAksyXlMACgkQBUrOwgisBPnhlgCgowvsxHKOblKAx2G8Q/eS2Pvk
> kakAnRX8Y/juvkbD13Rk94GFQqCeVuvX
> =A1V1
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> darcs-users mailing list
> darcs-users at darcs.net
> http://lists.osuosl.org/mailman/listinfo/darcs-users
>
>


More information about the darcs-users mailing list