[darcs-users] darcs patch: Make Haskeline a required dependency (+ 4 more)

Trent W. Buck trentbuck at gmail.com
Wed Feb 4 01:36:44 UTC 2009

Eric Kow <kowey at darcs.net> writes:

> First of all: anybody have objections to this in principle?

Not in principle.

I'm a little nervous about making Darcs 2.3 unavailable for Debian
users, since it already requires a version of the cabal package that
isn't available except in experimental (as part of the GHC 6.10
package), and haskeline is not available as a Debian package at all.

Ultimately that depends on whether Debian 5.0 will be released in the
next six months (before Darcs 2.3) and if so, if we can get GHC 6.10
into Debian/testing or even Debian/unstable.

(It looks like Haskeline works with GHC 6.8, but I don't think any
Debian Developers are interested in producing new GHC 6.8 library
packages right now.)

>> Tue Feb  3 08:48:24 Pacific Standard Time 2009  Judah Jacobson
>> <judah.jacobson at gmail.com>
>>   * Don't use the bytestring-mmap package on Windows.
>>     M ./darcs.cabal -2 +2

I imagine this patch can be applied regardless, as Petr has already said
that bytestring-mmap is only used on Unix-like systems.

More information about the darcs-users mailing list