[darcs-users] darcs patch: Make Haskeline a required dependency (+ 4 more)

Petr Rockai me at mornfall.net
Wed Feb 4 07:54:23 UTC 2009


trentbuck at gmail.com (Trent W. Buck) writes:
>> First of all: anybody have objections to this in principle?
>
> Not in principle.
>
> I'm a little nervous about making Darcs 2.3 unavailable for Debian
> users, since it already requires a version of the cabal package that
> isn't available except in experimental (as part of the GHC 6.10
> package), and haskeline is not available as a Debian package at all.
In the worst-case scenario, we can package haskeline ourselves.

> Ultimately that depends on whether Debian 5.0 will be released in the
> next six months (before Darcs 2.3) and if so, if we can get GHC 6.10
> into Debian/testing or even Debian/unstable.
I definitely hope so. And even if it doesn't, I wouldn't expect darcs 2.3 to
get in, unless there's a serious archive thaw.

> (It looks like Haskeline works with GHC 6.8, but I don't think any
> Debian Developers are interested in producing new GHC 6.8 library
> packages right now.)
It does, that's what I test with on my laptop.

All in all, I don't think that "hackage package foo is missing in distribution
bar" is really an important issue to be worrying about. I don't know where the
cabal-debian tool by seareason went, but we could probably leverage that as
well.

Yours,
   Petr.

-- 
Peter Rockai | me()mornfall!net | prockai()redhat!com
 http://blog.mornfall.net | http://web.mornfall.net

"In My Egotistical Opinion, most people's C programs should be
 indented six feet downward and covered with dirt."
     -- Blair P. Houghton on the subject of C program indentation


More information about the darcs-users mailing list