[darcs-users] darcs patch: Make Haskeline a required dependency (+ 4 more)

Trent W. Buck trentbuck at gmail.com
Wed Feb 4 10:19:30 UTC 2009

On Wed, Feb 04, 2009 at 08:54:23AM +0100, Petr Rockai wrote:
> trentbuck at gmail.com (Trent W. Buck) writes:
>>> First of all: anybody have objections to this in principle?
>> Not in principle.
>> I'm a little nervous about making Darcs 2.3 unavailable for Debian
>> users, since it already requires a version of the cabal package
>> that isn't available except in experimental (as part of the GHC
>> 6.10 package), and haskeline is not available as a Debian package
>> at all.
> In the worst-case scenario, we can package haskeline
> ourselves. [...]  All in all, I don't think that "hackage package
> foo is missing in distribution bar" is really an important issue to
> be worrying about.

Yeah, you're right.  I just don't want to turn around in two years and
discover that I've somehow volunteered to look after Debian
integration for half-a-dozen Haskell libraries merely in order to keep
Darcs in Debian.

>> Ultimately that depends on whether Debian 5.0 will be released in the
>> next six months (before Darcs 2.3) and if so, if we can get GHC 6.10
>> into Debian/testing or even Debian/unstable.
> I definitely hope so. And even if it doesn't, I wouldn't expect darcs 2.3 to
> get in, unless there's a serious archive thaw.

If I understand correctly, we're supposed to use experimental instead
of unstable until Lenny is released, because not doing so makes life
harder for the release team (in particular, if they want to fix rc
bugs without pulling in a new major upstream release).

> I don't know where the cabal-debian tool by seareason went, but we
> could probably leverage that as well.

I had a look at it, and I feel it needs a lot more work before it can
be used for official packages.

More information about the darcs-users mailing list