[darcs-users] darcs patch: Make Haskeline a required dependency (2nd try)

Judah Jacobson judah.jacobson at gmail.com
Sun Feb 8 20:45:03 UTC 2009


On Fri, Feb 6, 2009 at 1:28 PM, Judah Jacobson <judah.jacobson at gmail.com> wrote:
> I've released a new version of Haskeline (0.6.1) which should fix the
> issues that were reported.  I'm attaching the previous patches again,
> plus one more which bumps the required Haskeline version in the Cabal
> file.
>
> So to install this new version of Haskeline, either download it from
> Hackage or use:
>
> cabal update && cabal install haskeline
>
> If you're building darcs with MacPorts, Haskeline will need to be
> linked against MacPorts' libiconv.  You can do that by passing the
> following arguments to "runghc Setup configure" or "cabal install
> haskeline":
>
> --extra-include-dirs=/opt/local/include --extra-lib-dirs=/opt/local/lib

Actually, after further examination it looks like this may not always
be necessary, depending on what environmental flags are set.  I'd be
interested to hear other peoples' experiences with this.

Thanks,
-Judah


More information about the darcs-users mailing list