[darcs-users] retiring GHC 6.6 support after darcs 2.3 (2009-07)

Eric Kow kowey at darcs.net
Sun Feb 15 20:42:46 UTC 2009


On Sun, Feb 15, 2009 at 21:22:41 +0100, Matthias Kilian wrote:
> Didn't you that by depending on haskeline? At least I couldn't build
> haskeline with ghc-6.6 on openbsd.

Actually, the Haskeline dependency still hasn't made it in yet because
of the trouble folks had installing haskeline.  Judah is still working
on it.  For what it's worth, I managed to install haskeline on ghc-6.6
on Ubuntu, although I think I was using a cabal-install binary built
with ghc 6.10.

Could you report any trouble on
  http://trac.haskell.org/haskeline/wiki
?

This is one area where I messed up by being too eager.  I simply had
not anticipated the platform support issues that would arise.  Judah:
would it make sense to wait till darcs 2.3 for Haskeline to be the
default, or should we press ahead?

> > Good?
> 
> Not so good for openbsd, but that's not your fault.

Hmm, is a later version of GHC not available for OpenBSD?

Thanks!

-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20090215/c7a96dcb/attachment.pgp>


More information about the darcs-users mailing list