[darcs-users] please install utf8-string on your buildslaves

Eric Kow kowey at darcs.net
Thu Feb 19 13:17:43 UTC 2009


Dear darcs buildslave owners,

I am about to apply the following patch, which will require the
utf8-string module by default.  Could you please

  cabal install utf8-string

on your build slaves?

I'm sorry to make so many requests of this sort.  There may be more to
come as we continue moving towards greater use of third-party modules.
Hopefully, we will be better able to coordinate future requests of this
type so you can just meet them in one go.

Please let me know if you need any help,

PS. Zooko: I am puzzled by the situation on nooxie.  It claims to have
GHC 6.10.1 (and consequently Cabal 1.6) installed, yet it reports:

    Could not find module `Distribution.Text':

I wonder if the version of cabal-install makes a difference.  What
does cabal -V report?

On Wed, Feb 18, 2009 at 10:15:53 +0000, Eric Kow wrote:
> Tue Feb 17 15:31:11 GMT 2009  Eric Kow <kowey at darcs.net>
>   * Cabal: require utf8-string by default.
>   The user can go back to the internal utf8-string binding with cabal configure -f-utf8-string

-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20090219/1c80611d/attachment.pgp>


More information about the darcs-users mailing list