[darcs-users] darcs patch: Cabal: require utf8-string by default. (and 2 more)

Eric Kow kowey at darcs.net
Sat Feb 21 14:44:14 UTC 2009


I'm only re-sending the first one because the others depend on it (I'm going to
wait a day or two for buildslave owners to install utf8-string before pushing
that first patch)

Tue Feb 17 15:31:11 GMT 2009  Eric Kow <kowey at darcs.net>
  * Cabal: require utf8-string by default.
  The user can go back to the internal utf8-string binding with cabal configure -f-utf8-string

Sat Feb 21 14:36:26 GMT 2009  Eric Kow <kowey at darcs.net>
  * Simplify flag names to just refer to hackage names.

Contrary to my first remark that external-bytestring should be retained
(because of the distinction between GHC 6.6's internal Data.Bytestring and the
bytestring package), I decided that Petr was probably right that we should
simply just use the hackage package name for the flag and be done with it...

Sat Feb 21 14:38:24 GMT 2009  Eric Kow <kowey at darcs.net>
  * Sunset the external-bytestring flag (it goes out after 2009-07).

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: text/x-darcs-patch
Size: 24912 bytes
Desc: A darcs patch for your repository!
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20090221/eacd5f6c/attachment-0001.bin>


More information about the darcs-users mailing list