[darcs-users] darcs patch: Add an executable to darcs.cabal to build unit tests

Reinier Lamers tux_rocker at reinier.de
Sat Feb 28 12:03:07 UTC 2009


Hi,

On Saturday 28 February 2009 11:25:17 Eric Kow wrote:
> On Sat, Feb 28, 2009 at 10:20:38 +0000, Eric Kow wrote:
> > On Sat, Feb 28, 2009 at 11:11:32 +0100, Reinier Lamers wrote:
> > > Fri Feb 27 21:35:24 CET 2009  Reinier Lamers <tux_ro	cker at reinier.de>
> > >   * Add an executable to darcs.cabal to build unit tests	
> >
> > Hooray!  (applied, thanks!)
>
> Argh, spoke too soon: not applied yet.
>
> (1) I get cabal: These flags are used without having been defined:
>     external-zlib, external-bytestring

What command do you enter that gives you that warning? When I do "cabal clean" 
or "cabal configure" or "cabal build", I don't get any warnings. "cabal check" 
only mutters a bit about -O2 causing long compile times.

But now at once I get linker errors :-( when linking the unit executable:

/home/reinier/.cabal/lib/QuickCheck-2.1.0.1/ghc-6.10.1/libHSQuickCheck-2.1.0.1.a(Arbitrary.o): 
In function `sb1a_info':
(.text+0x1c03f): undefined reference to 
`__stginit_basezm3zi0zi3zi0_DataziRatio_'

I just did a fresh cabal install --reinstall of QuickCheck-2.1.0.1, so what 
the...?

Regards,
Reinier
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20090228/9d5df34b/attachment.pgp>


More information about the darcs-users mailing list