[darcs-users] darcs 2.3 beta 1: configure fails with GHC 6.8.3 on FreeBSD

Mark Stosberg mark at summersault.com
Wed Jul 8 17:49:58 UTC 2009

On Tue, 07 Jul 2009 21:16:50 +0200
Petr Rockai <me at mornfall.net> wrote:

> Mark Stosberg <mark at summersault.com> writes:
> > I tried installing from this tarball with GHC 6.8.3 with the following
> > result:
> >
> >  $ runghc Setup configure
> >  
> >  Setup.lhs:31:7:
> >      Could not find module `Distribution.Text':
> >        Use -v to see a list of the files searched for.
> >
> > ###
> >
> > This is on a FreeBSD system.
> You need to upgrade your Cabal to version 1.6. If you have
> cabal-install, saying "cabal install Cabal" should fix your
> problem. Otherwise, you probably need to download a cabal 1.6 tarball
> and install manually.
> (We may need to add some instructions to README to that effect...)

Thanks Petr.  This helped me to get further:

- I downloaded cabal-install from here: http://www.haskell.org/cabal/download.html
- Then I ran "sh bootstrap.sh" and followed the eventual instructions
  about moving "cabal" to my path.

- Now I returned to the darcs directory and did "cabal configure". 
  It failed like this:

  Configuring darcs-
  setup: At least the following dependencies are missing:
  hashed-storage >= && <0.4 && >= && <0.4,
  haskeline >=0.6.1 && <0.7 && >=0.6.1 && <0.7

It would be great if there was a solution like cabal's "bootstrap.sh"
which automates the fetching and building of dependencies. (bootstrap.sh
worked gracefully even without root access). Short of that, it would be
a better user experience if "cabal configure" would provide more detail
about how to find and install these dependencies when they are missing.
Keep in mind that many target users aren't Haskell users and shouldn't
be expected to know what may be standard Haskell package installation

Also, it appears there's some kind of bug in the configure system, so
that the version ranges for dependencies are needlessly given twice, 
for example:

  hashed-storage >= && <0.4 && >= && <0.4,

I am happy to leave autotools behind and look forward to to the new and
improved Cabal installation experience.


More information about the darcs-users mailing list