[darcs-users] darcs falling back to wget (no libcurl support?)

Eric Kow kowey at darcs.net
Thu Mar 5 09:31:14 UTC 2009


Hi all,

Recently, I've noticed that my local copy of darcs has been falling back
to wget as though it was being built without libcurl.

Any ideas what might be going on?

I can file a bug report, of course.

$ cabal configure --verbose
/usr/local/bin/ghc --numeric-version
looking for package tool: ghc-pkg near compiler in /usr/local/bin
found package tool in /usr/local/bin/ghc-pkg
/usr/local/bin/ghc-pkg --version
/usr/local/bin/ghc --supported-languages
Reading installed packages...
/usr/local/bin/ghc-pkg dump --global
/usr/local/bin/ghc-pkg dump --user
Reading available packages...
Resolving dependencies...
selecting darcs-2.2.0 (hackage) and discarding haskeline-0.3.2 and
terminfo-0.2.2.1
selecting array-0.2.0.0 (installed)
selecting bytestring-0.9.1.4 (installed)
selecting bytestring-mmap-0.2.0 (installed)
selecting containers-0.2.0.0 (installed)
selecting directory-1.0.0.2 (installed)
selecting filepath-1.1.0.1 (installed)
selecting ghc-prim-0.1.0.0 (installed)
selecting haskeline-0.6.0.1 (installed)
selecting extensible-exceptions-0.1.1.0 (installed)
selecting html-1.0.1.2 (installed)
selecting integer-0.1.0.0 (installed)
selecting mtl-1.1.0.2 (installed)
selecting old-locale-1.0.0.1 (installed)
selecting old-time-1.0.0.1 (installed)
selecting random-1.0.0.1 (installed)
selecting regex-compat-0.71.0.1 (installed)
selecting regex-base-0.72.0.2 (installed)
selecting regex-posix-0.72.0.3 (installed)
selecting rts-1.0 (installed)
selecting syb-0.1.0.0 (installed)
selecting terminfo-0.3 (installed)
selecting unix-2.3.1.0 (installed)
selecting utf8-string-0.3.3 (installed)
selecting process-1.0.1.1 (installed) and discarding process-1.0.1.0
selecting parsec-2.1.0.1 (installed) and discarding parsec-3.0.0
selecting base-3.0.3.0 (installed) and 4.0.0.0 (installed)
Creating ./dist/setup (and its parents)
./dist/setup/setup configure --verbose=2 --ghc
--prefix=/home/eykk10/.cabal
--user --flags=-test --flags=base3 --flags=mmap --flags=color
--flags=-type-witnesses --flags=-curses --flags=terminfo
--flags=haskeline
--flags=utf8-string --flags=-zlib --flags=bytestring --flags=http
--flags=libwww --flags=-curl-pipelining --flags=curl --constraint=array
==0.2.0.0 --constraint=base ==3.0.3.0 --constraint=bytestring ==0.9.1.4
--constraint=bytestring-mmap ==0.2.0 --constraint=containers ==0.2.0.0
--constraint=directory ==1.0.0.2 --constraint=filepath ==1.1.0.1
--constraint=haskeline ==0.6.0.1 --constraint=html ==1.0.1.2
--constraint=mtl
==1.1.0.2 --constraint=old-time ==1.0.0.1 --constraint=parsec ==2.1.0.1
--constraint=process ==1.0.1.1 --constraint=random ==1.0.0.1
--constraint=regex-compat ==0.71.0.1 --constraint=terminfo ==0.3
--constraint=unix ==2.3.1.0 --constraint=utf8-string ==0.3.3
Configuring darcs-2.2.0...
Flags chosen: test=False, base3=True, mmap=True, color=True,
type-witnesses=False, curses=False, terminfo=True, haskeline=True,
utf8-string=True, zlib=False, bytestring=True, http=True, libwww=True,
curl-pipelining=False, curl=True
Dependency array >=0.1 && <0.3 && >=0.1 && <0.3 && >=0.1 && <0.3 &&
==0.2.0.0:
using array-0.2.0.0
Dependency base ==3.* && >=3 && ==3.* && ==3.0.3.0: using base-3.0.3.0
Dependency bytestring >=0.9.0 && <0.10 && >=0.9.0 && <0.10 && >=0.9.0 &&
<0.10
&& ==0.9.1.4: using bytestring-0.9.1.4
Dependency bytestring-mmap >=0.2 && >=0.2 && >=0.2 && ==0.2.0: using
bytestring-mmap-0.2.0
Dependency containers >=0.1 && <0.3 && >=0.1 && <0.3 && >=0.1 && <0.3 &&
==0.2.0.0: using containers-0.2.0.0
Dependency directory ==1.0.* && ==1.0.* && ==1.0.* && ==1.0.0.2: using
directory-1.0.0.2
Dependency filepath ==1.1.* && ==1.1.* && ==1.1.0.1: using
filepath-1.1.0.1
Dependency haskeline ==0.6.* && ==0.6.* && ==0.6.0.1: using
haskeline-0.6.0.1
Dependency html ==1.0.* && ==1.0.* && ==1.0.1.2: using html-1.0.1.2
Dependency mtl >=1.0 && <1.2 && >=1.0 && <1.2 && ==1.1.0.2: using
mtl-1.1.0.2
Dependency old-time ==1.0.* && ==1.0.* && ==1.0.* && ==1.0.0.1: using
old-time-1.0.0.1
Dependency parsec >=2.0 && <3.1 && >=2.0 && <3.1 && ==2.1.0.1: using
parsec-2.1.0.1
Dependency process ==1.0.* && ==1.0.* && ==1.0.* && ==1.0.1.1: using
process-1.0.1.1
Dependency random ==1.0.* && ==1.0.* && ==1.0.* && ==1.0.0.1: using
random-1.0.0.1
Dependency regex-compat >=0.71 && <0.94 && >=0.71 && <0.94 &&
==0.71.0.1:
using regex-compat-0.71.0.1
Dependency terminfo ==0.3.* && ==0.3.* && ==0.3.* && ==0.3: using
terminfo-0.3
Dependency unix >=1.0 && <2.4 && >=1.0 && <2.4 && >=1.0 && <2.4 &&
==2.3.1.0:
using unix-2.3.1.0
Dependency utf8-string ==0.3.* && ==0.3.* && ==0.3.3: using
utf8-string-0.3.3
Using Cabal-1.6.0.2 compiled by ghc-6.10
Using compiler: ghc-6.10.1
Using install prefix: /home/eykk10/.cabal
Binaries installed in: /home/eykk10/.cabal/bin
Libraries installed in: /home/eykk10/.cabal/lib/darcs-2.2.0/ghc-6.10.1
Private binaries installed in: /home/eykk10/.cabal/libexec
Data files installed in: /home/eykk10/.cabal/share/darcs-2.2.0
Documentation installed in: /home/eykk10/.cabal/share/doc/darcs-2.2.0
Using alex version 2.2 found on system at: /home/eykk10/.cabal/bin/alex
Using ar found on system at: /usr/bin/ar
No c2hs found
Using cpphs version 1.6 found on system at:
/home/eykk10/.cabal/bin/cpphs
No ffihugs found
Using gcc version 4.3.2 found on system at: /usr/bin/gcc
Using ghc version 6.10.1 found on system at: /usr/local/bin/ghc
Using ghc-pkg version 6.10.1 found on system at: /usr/local/bin/ghc-pkg
No greencard found
Using haddock version 2.4.1 found on system at:
/home/eykk10/.cabal/bin/haddock
Using happy version 1.17 found on system at:
/home/eykk10/.cabal/bin/happy
No hmake found
Using hsc2hs version 0.67 found on system at: /usr/local/bin/hsc2hs
Using hscolour version 1.11 found on system at:
/home/eykk10/.cabal/bin/HsColour
No hugs found
No jhc found
Using ld found on system at: /usr/bin/ld
Using libwww-config version 5.4.0 found on system at:
/usr/bin/libwww-config
No nhc98 found
Using pkg-config version 0.22 found on system at: /usr/bin/pkg-config
Using ranlib found on system at: /usr/bin/ranlib
Using strip found on system at: /usr/bin/strip
Using tar found on system at: /bin/tar
/usr/bin/gcc /tmp/966.c -o /tmp/966 -D__GLASGOW_HASKELL__=610 -Isrc
-Isrc -I. -DHAVE_SIGNALS -DHAVE_CURL -DHAVE_MMAP -DHAVE_BYTESTRING
-DHAVE_UTF8STRING -DHAVE_TERMINFO -DHAVE_HASKELINE -DHAVE_SIGNALS
-DHAVE_CURL -DHAVE_MMAP -DHAVE_BYTESTRING -DHAVE_UTF8STRING
-DHAVE_TERMINFO -DHAVE_HASKELINE -DHAVE_CURL -D_REENTRANT -DHAVE_CURL
-D_REENTRANT
-I/home/eykk10/.cabal/lib/process-1.0.1.1/ghc-6.10.1/include
-I/usr/local/stow/ghc-6.10.1/lib/ghc-6.10.1/directory-1.0.0.2/include
-I/usr/local/stow/ghc-6.10.1/lib/ghc-6.10.1/old-time-1.0.0.1/include
-I/home/eykk10/.cabal/lib/bytestring-mmap-0.2.0/ghc-6.10.1/include
-I/usr/local/stow/ghc-6.10.1/lib/ghc-6.10.1/unix-2.3.1.0/include
-I/usr/local/stow/ghc-6.10.1/lib/ghc-6.10.1/bytestring-0.9.1.4/include
-I/usr/local/stow/ghc-6.10.1/lib/ghc-6.10.1/base-4.0.0.0/include
-I/usr/local/stow/ghc-6.10.1/lib/ghc-6.10.1/include -IPAPI_INCLUDE_DIR
-lcurl -lz -lz -lcurl -lz


-- 
Eric Kow <http://www.nltg.brighton.ac.uk/home/Eric.Kow>
PGP Key ID: 08AC04F9
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Digital signature
URL: <http://lists.osuosl.org/pipermail/darcs-users/attachments/20090305/f8eced10/attachment.pgp>


More information about the darcs-users mailing list