[darcs-users] Data loss bug when renaming and replacing a non standard token?

Ashley Moran ashley.moran at patchspace.co.uk
Sun Mar 22 22:15:03 UTC 2009


On Mar 22, 2009, at 9:52 pm, Eric Kow wrote:

> Argh!  Sorry about that.  If it's any consolation, I'm relieved it's
> 'just' working directory lost, although I understand that this can  
> be a
> pretty big deal :-(

As it happens, in this case it was only 5 or 6 lines of code, that  
were pretty similar to the ones above.  So it was not a big deal.  But  
it's a bit scary to think it could have affected dozens of lines of  
new code!


>> Hmm, can I forward the original email to that address?
>
> I expect that to work.

Done - first bug I've reported to darcs, I assume that's created a  
ticket ok.  I got an email back.


> Ooh.  Well I know that you have a system to keep you on top of things,
> so please do take your time.

That's right =)  I don't forget things, but some of them take me a  
long time to do!


> I would advocate just starting by submitting what you have as a test
> case (it's pretty simple; the key to the test cases is [a] they are
> shell scripts and [b] any non-zero exit code is treated as a failure
> unless explicitly accounted for).


Dan seems to have investigated this in some detail.  Is there anything  
else I can provide beyond turning the email into a script?   
(Presumably just a grep for the missing data would prove the point.)

Ashley

-- 
http://www.patchspace.co.uk/
http://www.linkedin.com/in/ashleymoran
http://aviewfromafar.net/
http://twitter.com/ashleymoran



More information about the darcs-users mailing list