[darcs-users] darcs error: "cannot handle mergers" ??

Steven G. Johnson stevenj.mit at gmail.com
Mon Mar 23 10:44:56 UTC 2009


I recompiled darcs 1.0.9 with this patch (added right after the Merger  
_ "0.9" line), and re-ran darcs optimize --modernize, but darcs  
version 2.0.2 still gives the same error message, unfortunately.

On Mar 22, 2009, at 3:51 PM, Eric Kow wrote:
> Hi Steven,
>
> Any luck with the below?
>
> On Wed, Mar 18, 2009 at 18:24:25 -0700, David Roundy wrote:
>>
>> The easy fix is to add (to 1.0.9) another line reading
>>
>> modernize_patch p@(Merger _ "0.1" _ _ _ _) = merger_equivalent p
>>
>> which should fix this.




More information about the darcs-users mailing list