[darcs-users] darcs error: "cannot handle mergers" ??
Trent W. Buck
trentbuck at gmail.com
Tue Mar 24 22:38:17 UTC 2009
Eric Kow <kowey at darcs.net> writes:
> Hi Steve and David,
> On Mon, Mar 23, 2009 at 06:44:56 -0400, Steven G. Johnson wrote:
>> I recompiled darcs 1.0.9 with this patch (added right after the Merger _
>> "0.9" line), and re-ran darcs optimize --modernize, but darcs version
>> 2.0.2 still gives the same error message, unfortunately.
> Thanks for trying.
> I've established that the --modernize-patches first appeared in darcs
> 1.0.4... which I wasn't able to build with GHC 6.6.1.
> So right now, our easy options right now are to (a) look for a later
> version of darcs which still knows how to modernize those particular
> mergers and which compiles with a relatively recent GHC or (b) find a
> way to install GHC 6.4 on your machine (c) somehow convince darcs
> 1.0.4 to build with a relatively modern GHC (say 6.6).
There are binaries for 1.0.4 for Debian here:
More information about the darcs-users